MatrixSSL Unaffected by SSL 3.0 POODLE Vulnerability

MatrixSSL Unaffected by SSL 3.0 POODLE Vulnerability

Oct 14, 2014

Security Measures

  • POODLE Vulnerability in SSL 3.0 - An attack against the SSL 3.0 random padding method for block ciphers was proven to be feasible. This was a known weakness and fixed in TLS 1.0 (SSL version 3.1), but only recently was attack code produced. MatrixSSL is not affected by the POODLE vulnerability: SSL 3.0 is disabled by default since version 3.3.1 on July 16, 2012. We recommend deprecating use of SSL 3.0 and moving directly to TLS 1.2.


Subscribe

Subscribe via RSS.

Tags

News (22) Releases (50)

Recent Posts

About

MatrixSSL™ is an embedded SSL and TLS implementation designed for small footprint applications and devices.

Links

Company

Copyright (c) INSIDE Secure Corp., 2002-2017. All Rights Reserved.